Oops I deleted the server
Incident Report for Riju
Resolved
I think I can declare this resolved for now. We'll see if any bug reports trickle in.
Posted Dec 11, 2021 - 22:29 UTC
Update
Oh, I'm just being silly, the issue is I didn't see the script tag because I moved it to the top of the page.
Posted Dec 11, 2021 - 22:27 UTC
Update
Things look good, although I'll continue keeping an eye out. The main issue is we lost analytics. Working on figuring out what's the deal with that.
Posted Dec 11, 2021 - 22:26 UTC
Monitoring
Ah, updating the app container to the latest version seems to have fixed the problem---I had forgotten that I had yet not deployed that change at the time when I accidentally switched the AMI.
Posted Dec 11, 2021 - 22:25 UTC
Update
So I've put the staging instance into production, however, the problem is it's suffering from an issue that blocks containers from being created, which is discussed at https://github.com/kubernetes/kubernetes/issues/72878. You can see for yourself in the JavaScript console at https://riju.codes/python#debug.
Posted Dec 11, 2021 - 22:21 UTC
Identified
I clicked the wrong button in the EC2 console so now there is not a healthy server available. Working on figuring out how to obtain one.
Posted Dec 11, 2021 - 22:19 UTC
This incident affected: Web interface.