Unidentified CPU and memory spike
Incident Report for Riju
Postmortem
Posted Oct 22, 2021 - 05:50 UTC

Resolved
Five minutes of unavailability because some user code maxed out CPU and memory, which normally shouldn't be possible due to cgroup sandboxing. Root cause is currently unknown but kernel logs suggest that some pathological Racket code was the instigator of the incident :P
Posted Oct 22, 2021 - 05:15 UTC